PDA

View Full Version : Strange central locking problem.



[TUFFTR]
11-06-2010, 07:02 AM
This is on the Diamante, key only, no remote.
Insert key into drivers door, turn to left, doors unlock, key returns to neutral position, door's lock.

I've honestly never worked with central locking before so I have no idea where to start looking. All i know is this isn't related to a BEM or remote control or anything cause it has none of those, just would like to know where to start looking?

So yeah unlocks then re-locks in the neutral position which isnt very handy.

GT-Pete
11-06-2010, 08:00 AM
My guess would be mechanical malfunction in the locking mechanism or electical contact at the back of the lock on the drivers door

- Can you lock and unlock it properly from the lock/unlock switch?
- Can you lock and unlock it properly from the interior lock button on the drivers door?
- Can you lock and unlock it from the passenger door interior lock?

spud100
11-06-2010, 09:34 AM
Has a similar problem on a KS Verada touring wagon.

Inside each lock actuator there is a quadrant that flips from side to side.
In the housing on each side there is a small rubber pad so the quadrant does not smash onto the outer housing.
One pad had disintegrated so the quadrant then over travelled.
This meant that it then just rapidly cycled the locking system from unlock to lock.

The difficult bit is working out which actuator is the culprit.
Start with the drivers door then the front passenger one.
I opened up the actuator and glued a piece of rubber in place of the pad.
This fixed the problem.

Hope that this helps.
Gerry

[TUFFTR]
11-06-2010, 10:23 AM
My guess would be mechanical malfunction in the locking mechanism or electical contact at the back of the lock on the drivers door

- Can you lock and unlock it properly from the lock/unlock switch?
- Can you lock and unlock it properly from the interior lock button on the drivers door?
- Can you lock and unlock it from the passenger door interior lock?

1) Yep, sometimes "self locks" on it's own as-well though.
2) Yep works fine from inside tab on the door
3) Central on the diamante only works from the drivers side, well for as long as I've owned it anyway!


Has a similar problem on a KS Verada touring wagon.

Inside each lock actuator there is a quadrant that flips from side to side.
In the housing on each side there is a small rubber pad so the quadrant does not smash onto the outer housing.
One pad had disintegrated so the quadrant then over travelled.
This meant that it then just rapidly cycled the locking system from unlock to lock.

The difficult bit is working out which actuator is the culprit.
Start with the drivers door then the front passenger one.
I opened up the actuator and glued a piece of rubber in place of the pad.
This fixed the problem.

Hope that this helps.
Gerry

Yeah I think I've seen what your talking about before. Might do that tomorrow as I'm not in the mood to take the door skin off again (even though its only 5 mins) Just remember the problem I am having is not the typical "lock, unlock, lock, unlock" thing, but you may be right, cheers.

fat35l
11-06-2010, 04:53 PM
mine is the same

[TUFFTR]
18-06-2010, 05:28 PM
so anyone else got anything? Took off the door trim, well not much to suss out really just one microswitch on the drivers doorhandle.

Could it be the relay? As it doesnt cycle through lock/unlock, just when I go to the left to unlock I have to keep it there (keep coil of relay energized?) because upon returning to the centre position it locks.

Funny though that on cold mornings, it wont do it for the first key entry.

phonetech
22-06-2010, 07:39 AM
Paul
Just a long shot but if you have a spare central locking relay lying around try that it could be a faulty relay inside. Dont know where its mounted in the Diamante but in my TS its attached to the fuse box.
Neil

spud100
22-06-2010, 09:15 AM
As I originally posted.
The problem, MAY, be in the actuator.
I have attached a couple of PDF's from the Manual so you can see where the problem may lie.



file:///C:/Data/Car/Ignition%20Key%20Antenna%20circuit.pdffile:///C:/Data/Car/Lock%20Actuator.pdf
Gerry

[TUFFTR]
22-06-2010, 10:13 AM
Paul
Just a long shot but if you have a spare central locking relay lying around try that it could be a faulty relay inside. Dont know where its mounted in the Diamante but in my TS its attached to the fuse box.
Neil

Already got a relay from the wreckers, when I tried to install it in the Diamante......ahhh....yeah wasn't there....so I have no idea where it could be lol.
Gerry, links ain't working but I'll try and suss it out today.

spud100
22-06-2010, 10:53 AM
Sorry about the link.
Found for some reason that I cannot post attachments.

What I was trying to show is that there is a flipper switch inside the front door lock actuators in the wiring diagram.
This is likely to be the problem area.
Gerry

[TUFFTR]
29-06-2010, 04:10 PM
Well now I know what your talking about :)

Went and got an actuator from the wreckers and just PRAYED TO GOD the one in the diamante was the same. Well luckily, it was :P

And...problem solved....braved the 8 degree's outside and used all of the remaining sunlight to fit it in. Car opens and closes like normal now! fantastic :D

I'm gonna take the one from the diamante apart so I have a better understanding of how these work...

schott68
30-11-2010, 05:43 PM
I'm having a prob with my locking too. When I first got the car, if you unlocked it without opening the door, the car would self lock. I just thought that was how it was supposed to work. It only became a problem when when I would open eith er via key or keyless that the door locks would go up and down for two seconds which would either go back to lock or be unlocked.

GoTRICE
30-11-2010, 07:46 PM
I'm having a prob with my locking too. When I first got the car, if you unlocked it without opening the door, the car would self lock. I just thought that was how it was supposed to work. It only became a problem when when I would open eith er via key or keyless that the door locks would go up and down for two seconds which would either go back to lock or be unlocked.

your central locking motor is probably shot. Mine would do that for 30s before it stopped until i replaced it.

[TUFFTR]
30-11-2010, 10:27 PM
Yep just the door actuator. Fiddly to take on and off the first time but after that is a charm