+ Reply to Thread
Results 1 to 2 of 2

Thread: oxygen sensors

  1. #1

    Join Date
    Jul 2005
    Location
    New South Wales
    Posts
    256

    Default oxygen sensors

    When the fuel consumption of my previous ride (TJ Magna) increased dramatically I replaced the oxygen sensor and fuel consumption dropped. Fortunately the TJ had only the one sensor, so inexpensive and easy.

    My current ride (380 GT with 140,000km) fuel consumption increased and I decided to replace the 4 oxygen sensors with Denso sensors. Recently got P0030 code. Fortunately I had kept the original sensors the car had been fitted with. I re-fitted the appropriate sensor (rear bank pre- cat) and not more error code and car runs fine.

    A few questions come to mind, these are:
    What company makes OE sensors for 380? I could find no markings on the OE sensors
    I thought Denso was good, but Heating circuit failure in about 5,000km? I checked and it is open circuit.
    Assuming the OE sensor is OK, will the brand mis-match result in issues?
    Are post cat sensors important (in Australia), as they only monitor cat performance and do not affect A-F mix?

  2. #2

    Join Date
    Aug 2012
    Location
    South Australia
    Posts
    107

    Default

    The original sensors are made by Bosch, it should be fine using a mismatch the ECU is only looking for a signal.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts