+ Reply to Thread
Page 8 of 8 FirstFirst ... 6 7 8
Results 71 to 76 of 76

Thread: Help please! Freaking headlight change!

  1. #71
    Formerly kj380 TreeAdeyMan's Avatar
    Join Date
    Nov 2008
    Location
    South Australia
    Posts
    2,568

    Default

    Slight thread mine.

    Four days ago my passenger side low beam (H4) headlight conked. Philips Xtreme +80. Less than six months since I had them installed.
    Got the GF to replace it with the stock (crap) H4 globe (I'm effing hopeless at changing these H4 globes, don't have the 'feel' needed).
    Then this morning the driver's side low beam conked as well. The other Philips Xtreme +80.
    That's the third time now I have blown the driver's side H4 globe, and once for the passenger side. Never blown a high beam (H7) globe. Car is five years old and has done just under 83,000k.
    Is this normal, or do I maybe have a wiring/relay/fuse problem?
    The GF is getting a bit fed up with all the H4 globe replacements, and is threatening to dump me.
    Help!
    Now Mitsu-less for the first time in 29 years!

  2. #72
    Grubco's Avatar
    Join Date
    Sep 2004
    Location
    New South Wales
    Posts
    1,343

    Default

    Mine's about 4.5 yrs old, just hit 75K, and still running original daggy bulbs. I can see the yellow in them even without your type to draw a comparison. I'll change them one day... looks too fiddly.
    Hope you can salvage your bulbs problem AND keep the girlfriend.
    Last edited by Grubco; 01-12-2010 at 04:56 PM.
    Retired from Mitsubishi ownership after 13 years. (At least I can now open all my windows without breaking them)

  3. #73
    rprodrive's Avatar
    Join Date
    Dec 2008
    Location
    Victoria
    Posts
    242

    Default

    Quote Originally Posted by kj380 View Post
    Slight thread mine.

    Four days ago my passenger side low beam (H4) headlight conked. Philips Xtreme +80. Less than six months since I had them installed.
    Got the GF to replace it with the stock (crap) H4 globe (I'm effing hopeless at changing these H4 globes, don't have the 'feel' needed).
    Then this morning the driver's side low beam conked as well. The other Philips Xtreme +80.
    That's the third time now I have blown the driver's side H4 globe, and once for the passenger side. Never blown a high beam (H7) globe. Car is five years old and has done just under 83,000k.
    Is this normal, or do I maybe have a wiring/relay/fuse problem?
    The GF is getting a bit fed up with all the H4 globe replacements, and is threatening to dump me.
    Help!
    It is the globe mate. Anything + doesn't last. Whether it is +50 or whatever. They have a shorter life span.

  4. #74
    DOMO KUN!!!!!!!!!!!! Mecha-wombat's Avatar
    Join Date
    Jun 2009
    Location
    New South Wales
    Posts
    5,373

    Default

    Yep I have some IPF globes in ATM but just had to replace highs

  5. #75
    Formerly kj380 TreeAdeyMan's Avatar
    Join Date
    Nov 2008
    Location
    South Australia
    Posts
    2,568

    Default

    OK, dropped into SCA Wednesday arvo and bought a pair of new Calibre high powered blue/white globes, while waiting for the Osram Nightbreakers to arrive from the UK. The Osrams will be used as spares. Only $28 the pair for the Calibres, bargain.
    Got the GF to fit them last night.
    Passenger side was relatively easy, as the clip/spring was still in place, even managed to undo it myself without stuffing it.
    Driver's side clip/spring was a complete PITA to get back in, it just kept falling out. 30 minutes later and the GF is ready to spit the dummy.
    Guessed that it might be a bit out of shape, maybe a bit too 'wide' and needed some 'closing up', had a fiddle with some pliers, hey presto it went back in & stayed back in!
    So the moral of the story is that it's relatively easy for a Klumzy Klutz like me to bend the retaining clip/spring bad enough that it no longer stays in place, and it pays to 'squeeze it up' a bit.
    I now have to shout the GF dinner for all her help.
    Last edited by TreeAdeyMan; 03-12-2010 at 06:43 AM.
    Now Mitsu-less for the first time in 29 years!

  6. #76

    Join Date
    Oct 2017
    Location
    Western Australia
    Posts
    4

    Default

    just swapped out my 4 globes.
    No issues.
    Thanks for advice.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts