+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16

Thread: 2005 Magna Security Light.

  1. #11

    Join Date
    Jan 2018
    Location
    Victoria
    Posts
    19

    Default

    Quote Originally Posted by leadfoot6 View Post
    I can't see any fuses/relays just for the alarm/security system.

    All I can see is a horn relay in the engine bay fuse box:



    (click to enlarge)

    Once again, I am sorry, but that is about the extent of the help that I can offer.

    My auto electrical skills are rather limited.
    Thanks for all your help to date.
    I have ordered a bonnet alarm switch.
    I'm going to replace the bonnet alarm switch with a known working one and see what happens.
    I will let you know...

  2. #12

    Join Date
    Jan 2018
    Location
    Victoria
    Posts
    19

    Default

    Quote Originally Posted by Gyro10 View Post
    Where is this little green security light?
    Right hand side bottom corner of the dash...

  3. #13

    Join Date
    Jan 2018
    Location
    Victoria
    Posts
    19

    Default

    Quote Originally Posted by midgo View Post
    Thanks for all your help to date.
    I have ordered a bonnet alarm switch.
    I'm going to replace the bonnet alarm switch with a known working one and see what happens.
    I will let you know...
    Update on this.

    The guy I ordered the bonnet switch from was quite good and rang me and we went through a few things, testing the alarm etc.
    After which he stated that the bonnet switch would not fix this issue for me and there is probably another electrical or door switch or BEM issue to blame.
    So he refunded the purchase price.
    So I am still searching for a cause of why the security light no longer works and I have no factory alarm...

  4. #14

    Join Date
    Nov 2020
    Location
    Tasmania
    Posts
    97

    Default

    Quote Originally Posted by midgo View Post
    Right hand side bottom corner of the dash...
    When is it supposed to come on, since neither of my TLs does?

  5. #15

    Join Date
    Jan 2018
    Location
    Victoria
    Posts
    19

    Default

    Quote Originally Posted by Gyro10 View Post
    When is it supposed to come on, since neither of my TLs does?
    It's supposed to come on when you exit the car with all doors, bonnet and boot shut and you push the lock button on your remote.
    It turns off after 30 seconds and then the factory alarm should be active.
    Does you model come fitted with a factory alarm as standard???

  6. #16

    Join Date
    Nov 2020
    Location
    Tasmania
    Posts
    97

    Default

    Well it starts beeping if you use the key in the door sometimes (rather than remote unlock)...
    Just checked, it does work, but it comes on when I am usually walking away from the car having seen it lock. Hence I never see it.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (1 members and 1 guests)

  1. midgo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts