+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16

Thread: TL Handbrake Issues

  1. #11
    buzzzfuzz's Avatar
    Join Date
    Jul 2011
    Location
    New South Wales
    Posts
    85

    Default

    Sorry for the epic bump but my handbrake died today I think. This morning when I started her up and slowly exiting my place I could hear squeaking as the car rolled along (rear right wheel) which disappeared after a while I think due to heat. However same noise when I came home from work just then and went to park with handbrake and it made a slight clanking noise under the car and now the handbrake itself is very loose to pull up and doesn't lock in fully now.. The car in D will still move when fully pulled up. Any ideas?

  2. #12
    ...
    Join Date
    Aug 2014
    Location
    New South Wales
    Posts
    697

    Default

    Quote Originally Posted by STEAMBUFF View Post
    Can I get Generic cables, both L/R for 2004 tl Magna. Thanks in advance
    I am not sure if generic cables are available, but Forum Sponsor Mits-Fix offers this Genuine item:

    https://www.ebay.com.au/itm/Hand-Bra...item2f240f16b0

    For anything Magna/Mitsubishi related call them on 1300-300-274


    Time stamp issues - POSTS OUT OF CHRONOLOGICAL ORDER - happening again.
    Last edited by leadfoot6; 07-12-2018 at 10:42 AM.

  3. #13
    ...
    Join Date
    Aug 2014
    Location
    New South Wales
    Posts
    697

    Default

    Delete duplicate post
    Last edited by leadfoot6; 07-12-2018 at 10:20 AM. Reason: Duplicate post

  4. #14

    Join Date
    Dec 2011
    Location
    South Australia
    Posts
    2

    Default

    Can I get Generic cables, both L/R for 2004 tl Magna. Thanks in advance

  5. #15

    Join Date
    Jun 2009
    Location
    South Australia
    Posts
    755

    Default

    my handbrake isn't good. It feels like it's only working on one side, and the equalizer lever under the centre console is way to one side. Is there a procedure here for replacing linings? it's a TW FWD wagon.

  6. #16
    ...
    Join Date
    Aug 2014
    Location
    New South Wales
    Posts
    697

    Default

    Here are some threads that I googled dealing with handbrake issues for 3rd gen. models.

    http://www.aussiemagna.com/forums/sh...d.php?t=102335

    http://www.aussiemagna.com/forums/sh...d.php?t=103209

    4 threads linked to here:

    https://www.google.com/search?q=hand...&bih=653&dpr=1

    which has a step by step adjustment procedure from the workshop manual here:

    http://www.aussiemagna.com/forums/sh...=1#post1603072

    Here is another thread with a good diagram from the workshop manual:

    http://www.aussiemagna.com/forums/sh...=1#post1629320

    The above material hopefully might give enough help.

    Some are with pictures.

    One worthwhile tip I was given by my instructor(Barry Lake - former editor of "Motor" magazine) at my first defensive driver training school that I did in 1981 at Sydney's then Amaroo Park Raceway, was to always hold the button of the handbrake "in" when applying it.

    Don't let it "click".

    It helps prevent wear on the mechanism.

    I have needed to spend next to no time over the years "fiddling" with handbrake mechanisms.....thankfully.
    Last edited by leadfoot6; 29-12-2018 at 01:29 PM.
    ...

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts