+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: anybody got a 380 with bent valves?

  1. #1

    Join Date
    Jan 2006
    Location
    Australia's Capital Territory
    Posts
    128

    Default anybody got a 380 with bent valves?

    Just been to Mitsi in Canberra, trying to sort out some rattles with my TJ and the service mgr was trying to say to me that they rarely get probs with the TJ Magna engines but that wasn't to say that it doesn't happen and then he pointed to a 380 with 5000kms on it which had thrown the cambelt and stuffed the motor.
    Which didn't really inspire me with a lot of confidence in my car considering I was getting a 2nd appraisal on the rattle in my car which one Mitsi dealer had diagnosed as being the cam belt tensioner.

    Anyway what happened to the 380 is a bit scary. More than likely its related to 1 in a million component failure or a manufacturing fault considering the low number of kms done.

  2. #2
    Veearex's Avatar
    Join Date
    Apr 2006
    Location
    Australia's Capital Territory
    Posts
    174

    Default

    Umm, nope. 26,000 and still going strong, as I would expect. And I dont baby it much either.

    Wouldnt have happened to be a Mitsu dealer in town by any chance?

  3. #3
    What will be next? M4DDOG's Avatar
    Join Date
    Jul 2004
    Location
    Victoria
    Posts
    9,162

    Default

    It can happen to any car, pretty rare, but it does happen.
    Please use the report a post feature, instead of replying and creating more work for the admin team. Thanks!

  4. #4
    Bain's Avatar
    Join Date
    Mar 2003
    Location
    Victoria
    Posts
    2,673

    Default

    Check your tension pulley and the bolt holding it in..

    Mine came loose and it was knocking up against the sidewall.

  5. #5
    Banned Disciple's Avatar
    Join Date
    Aug 2005
    Location
    Queensland
    Posts
    4,802

    Default

    Quote Originally Posted by Bain
    Check your tension pulley and the bolt holding it in..

    Mine came loose and it was knocking up against the sidewall.
    Was that on the Magna or the Ford Bain?

  6. #6
    om nom nom... bowls? Mrmacomouto's Avatar
    Join Date
    May 2006
    Location
    Victoria
    Posts
    2,148

    Default

    I have a first gen with a bent valve.
    Quote Originally Posted by Lucifer
    "I love Glenn"

  7. #7

    Join Date
    Jan 2006
    Location
    Australia's Capital Territory
    Posts
    128

    Default

    yep in the city, its silver.
    got my car back, said there was nothing wrong with it. other mitsi dealer said it would cost $800 to fix. still think theres something to the rattle i get, so will prob do it myself!

  8. #8
    Cummins's Avatar
    Join Date
    Jan 2005
    Location
    Australia's Capital Territory
    Posts
    308

    Default

    Talkin of Mitsubishi in braddon... I organise the servicing for my parents TH...had the 90,000km service done with the timing belt changed...was runnin rough when i got it back and was told it was the base idle adjustment, didn't have time to mess with it, took it back in and turns out they'd put the timing belt on 2 teeth out...so suffering a bit of a timing problem ...the apprentice is apparently not working there anymore...ud wanna hope so ...

    Cummins.
    www.cumminsracing.com.au
    1:09.73 @ Wakefield
    48.97sec 1lap/86.04sec 2 lap @ SDMA Hillclimb
    1:26 Oran Park GP(on 2nd of only 2 laps of the circuit!)

  9. #9
    Bain's Avatar
    Join Date
    Mar 2003
    Location
    Victoria
    Posts
    2,673

    Default

    Quote Originally Posted by Disciple
    Was that on the Magna or the Ford Bain?
    Magna . Happened while driving the Great Ocean Road.. Interesting to hear the horrible knocking sound as you enter a corner..

    It had its fare share of problems.. (not like the Ford though)
    Last edited by Bain; 17-11-2006 at 07:04 AM.

  10. #10
    MYV64U's Avatar
    Join Date
    Dec 2003
    Location
    New South Wales
    Posts
    150

    Default

    Quote Originally Posted by SteveTJ
    Just been to Mitsi in Canberra, trying to sort out some rattles with my TJ and the service mgr was trying to say to me that they rarely get probs with the TJ Magna engines but that wasn't to say that it doesn't happen and then he pointed to a 380 with 5000kms on it which had thrown the cambelt and stuffed the motor.
    Which didn't really inspire me with a lot of confidence in my car considering I was getting a 2nd appraisal on the rattle in my car which one Mitsi dealer had diagnosed as being the cam belt tensioner.

    Anyway what happened to the 380 is a bit scary. More than likely its related to 1 in a million component failure or a manufacturing fault considering the low number of kms done.
    I have a slight rattle in my 01 TJ and I am thinking cambelt tension as well. How much are they quoting you to repair?
    I will call him .... MINI MAGNA!
    (\_/)
    (O.o)
    (> <)

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts